Phone Mail

What are the computer requirements for trading at OptionsClick?

License no. 296/16 Highest Security standards

You can trade at OptionsClick using any standard PC with an internet connection.  You do not have to download any additional software in order to start trading.

OptionsClick recommends using Internet Explorer (IE7.0, IE8.0), FireFox (v3.5, v3.6), or Google Chrome (v4.0) as your Internet browser.

Java script must be enabled to trade in our site.

Flash player needs to be installed to view some site elements.

[ back to top ]

To keep trading with OptionsClick *“Agree” Please

* I accept all LTL’s (Leadtrade ) policies and terms and conditions